Troubleshooting

SCENARIO1: No content available
Description
: When the member, who is not an admin, logs in to FactoryTalk DataMosaix, the member can see the message, “No content available”.
Cause 1
: The member has access in FT Hub, but the admin has not assigned any role to the member in FactoryTalk DataMosaix.
Cause 2
: The admin has not created a project.
Solution
: Contact the project admin to assign the required role. When a project is created and role is assigned, the member should be able to see the content in FactoryTalk DataMosaix.
SCENARIO 2: You have no applications to display.
Description
: In a project, where applications do not exist and if a member logs in to FactoryTalk DataMosaix, the member is able to view the following message, “You have no applications to display” without the [Create App] button.
Cause
: This is because the member does not have the Data Scientist role.
Solution
: Contact the project admin to assign the Data Scientist role. Once the Data Scientist role is assigned, the member should see the [Create App] button and register applications.
SCENARIO 3: You have no data sources to display.
Description
: In a project, where extractors do not exist and if a member logs in to FactoryTalk DataMosaix, the member is able to view the following message, “You have no data sources to display” without the [Generate Info] button.
Cause
: This is because the member does not have the Data Configurator role.
Solution
: Contact the project admin to assign the Data Configurator role. Once the Data Configurator role is assigned, the member should see the [Generate Info] button and register extractors.
SCENARIO 4: Cannot view the [Add] icon to register application.
Description
: The member is not able view the [Add] icon to register new application. The member is only able to view the list of existing applications.
Cause
: This is because the member does not have the Data Scientist role.
Solution
: Contact the project admin to assign the Data Scientist role. Once the Data Scientist role is assigned, the member should see the [Add] button.
After the role is assigned, the member can view details of existing applications by clicking the application name and view the edit or delete options in the Actions column.
SCENARIO 5: Cannot view the [Add] icon to register extractor.
Description
: The member is not able view the [Add] icon to register new extractor. The member is only able to view the list of existing extractors.
Cause
: This is because the member does not have the Data Configurator role.
Solution
: Contact the project admin to assign the Data Configurator role. Once the Data Configurator role is assigned the member should see the [Add] button.
After the role is assigned, the member can view details of existing extractor by clicking the extractor name and view the edit and delete options in the Actions column.
SCENARIO 6: Pipeline not found.
Description
: While registering an extractor, when a member provides a pipeline name, the error 'Pipeline not found. Please check pipeline information provided' displays.
Cause
: This occurs when the pipeline by the provided name does not exist in CDF or the pipeline name does not match. The pipeline name is case sensitive.
Solution
: The member must ensure, the pipeline already exists in CDF and the pipeline name provided while registering the extractor matches with the pipeline name in CDF.
The extractor registers only after the pipeline name matches.
SCENARIO 7: Cannot modify member roles.
Description
: A member in FactoryTalk DataMosaix is not able to see the option to assign, edit, or remove roles for other members.
Cause
: Only a member who is assigned the Project admin role can modify member roles.
Solution
: The member must request the existing project admin to assign the project admin role.
SCENARIO 8: Extractor not working as expected or failing.
Description
: Old extractors configured before the 1.1.0 release, not working as expected or failing with error - 'Client has not been granted scopes: IDENTITY'.
Cause
: The IDENTITY scope was removed from the Auth0 token as a part of the 1.2.0 release as this scope is not required. It won’t affect the extractors registered after the FT DataMosaix 1.1.0 release.
Solution
: This issue can be fixed for the impacted extractors by making a slight modification in the config.yml file. Follow the instructions:
  1. Stop the running extractor.
  2. Open the config.yml file for the impacted extractor.
  3. Under the ‘
    # Information about CDF project
    ’ section, find the
    scopes
    subsection.
    For the impacted extractors, there should be 2 values present under the scopes like below.
    scopes:
       
    - user_impersonation
       
    - IDENTITY
  4. Remove the
    IDENTITY
    value from the scopes.
    Once you remove the
    IDENTITY
    value,
    the
    scopes
    section should look like:
    scopes:
       
    - user_impersonation
  5. Save the config.yml file.
    After saving the file, you can run the extractor and it should work as expected.
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